×

ترقية PHP إلى 7.2

سلام عليكم عندي سيرفر ديديكيتيد الاصدار تبع PHP الي عليه 7.1، وقاعد تجيني اخطاء من المواقع الي عليه خصوصاً جوملا انه لازم احدث الى 7.2
صورة 'رقيق آلمشاعر' الرمزية
قديمة 23 - 05 - 2020, 20:54
المشاركة 1
افتراضي

ترقية PHP إلى 7.2 بدون إجابة

سلام عليكم

عندي سيرفر ديديكيتيد الاصدار تبع PHP الي عليه 7.1، وقاعد تجيني اخطاء من المواقع الي عليه خصوصاً جوملا انه لازم احدث الى 7.2 او اكثر، لاهنتم طريقة اضافة الاصدار الاخير للسيرفر، وهل راح يأثر على المواقع خلال الترقية ؟ يعني راح تتوقف ولا تبقى شغالة ؟

مع الشكر
المشاهدات 59 | التعليقات 2
قديمة 24 - 05 - 2020, 05:11
المشاركة 2
صورة 'Mohamed.Belal' الرمزية
Mohamed.Belal
.:: عضو متألق ::.
تاريخ الإنضمام: 18 - 04 - 2008
رقم العضوية : 57039
الدولة : في مملكتي الخاصة
المشاركات: 9,135
28
افتراضي ترقية PHP إلى 7.2


سلام عليكم
لا ما راح تتاثر بس الافضل التحديث له

تقبل مروري


مـــــــــــطــــور مــــــــواقـــــــــــع
whatsup - imo - Telegram - viber
00201205448012

قديمة اليوم, 10:46
المشاركة 3
صورة 'Q82HoSt.CoM' الرمزية
Q82HoSt.CoM
:: عضو نشيط ::
تاريخ الإنضمام: 29 - 01 - 2008
رقم العضوية : 51431
الدولة : :: Where the Wind Will take me ::
المشاركات: 2,868
افتراضي ترقية PHP إلى 7.2
سلام عليكم

عندي سيرفر ديديكيتيد الاصدار تبع PHP الي عليه 7.1، وقاعد تجيني اخطاء من المواقع الي عليه خصوصاً جوملا انه لازم احدث الى 7.2 او اكثر، لاهنتم طريقة اضافة الاصدار الاخير للسيرفر، وهل راح يأثر على المواقع خلال الترقية ؟ يعني راح تتوقف ولا تبقى شغالة ؟

مع الشكر
التأثير على المواقع يعتمد على حسب السكربت او السكربتات الموجوده في كل موقع، لكل سكربت احتياجه الخاص بالأشياء التالية:-
- اصدار php - بعض السكربتات ممكن تجدها لا تدعم الاصدار 7 فما فوق .
- الموديولز (modules) المرتبطة بالPHP - بعض السكربتات تجدها تعتمد و تحتاج على بعض الموديولز في عملها و ربما بعض الموديولز لا تدعم الاصدار الجديد من php .
- الدوال (functions) - لكل سكربت له احتياجه الخاص من الدوال في php.
يجب عليك قبل البدأ بتغيير اصدار الphp في السيرفر، عمل قائمه بكل السكربتات التي تستخدمها، و لكل سكربت تقوم بالبحث عن متطلبات التشغيل الخاصه به من الموقع الذي قمت بشراء السكربت منه او من المبرمج،
فمثلا لمعرفة متطلبات سكربت المنتديات vBulletin الاصدار 4.2.5 اقوم بالبحث في قوقل بكتابة التالي:-
اقتباس
vbulletin 4.2.5 system requirements
مثال على صفحه المتطلبات من الموقع الام لvBulletin و التي تحدد متطلبات الاصدار 4.2.5 :-
https://www.vbulletin.com/docs/html?...rsion=40205500

اذا تطلب الامر بعد ان حصرت قائمه السكربتات التي لديك ووجدت مثلا سكربت يتطلب الاصدار 7 من php و سكربت آخر يتطلب الاصدار 5 من php فيمكنك بذلك تركيب الاصدارين على نفس السيرفر و تعديل الاعدادات الخاصة لكل موقع عن طريق ملفات اعدادات الاباتشي httpd.conf ان كنت تستخدم apache server او ملف nginx default.conf ان كنت تستخدم الNginx

تحياتي
---------------------------------------------------------------------
Business Inquries:-
[email protected]
مواضيع ذات صلة

 
اضافة رد
 

اخطاء فى MYSQL ع سيرفري " The MySQL Connection could not be established " مشكل في تنصيب mybb على استضافة مجانية

أدوات الموضوع ابحث في الموضوع
ابحث في الموضوع:

البحث المتقدم
طرق العرض


الساعة معتمدة بتوقيت جرينتش +3 . الساعة الآن : 19:22.
المعهد غير مسؤول عن أي اتفاق تجاري أو تعاوني بين الأعضاء
فعلى كل شخص تحمل مسئولية نفسه إتجاه مايقوم به من بيع وشراء وإتفاق وأعطاء معلومات موقعه
التعليقات المنشورة لا تعبر عن رأي معهد ترايدنت ولا نتحمل أي مسؤولية قانونية حيال ذلك (ويتحمل كاتبها مسؤولية النشر)

جميع الحقوق محفوظة Traidnt 2019
  • 00966138651070
  • 00966138648289
  • 2051033691
Powered by vBulletin® Version 3.8.11 .Copyright ©2000 - 2020, Jelsoft Enterprises Ltd
SEO by vBSEO ©2011, Crawlability, Inc.